Issues with the Microsoft Sculpt on USB-C MacBook Pros

Feel free to skip this if you do not want to hear about a very specific hardware issue I am having. I’m writing this so I have a reference document to point back to and share!

Updates

Update Dec. 10: Thought the powered USB hub had done the trick, but had a drop this morning. It did last a lot longer between drops than before. Back to the drawing board.

UPDATE Dec. 9: cautiously optimistic that I’ve found a fix! Chris Dzombak mentioned trying a powered USB hub. I found an Anker hub with a wall wart power supply in the closet and have been using the keyboard/mouse for 24 hours without any drops.

The Problem

A few years back after having some bad back pain I picked up a Microsoft Sculpt keyboard and mouse. It’s been such a lifesaver in terms of limiting pain. The only downside is that it uses a proprietary USB-A receiver that is linked to the keyboard and mouse it came with. Lose the receiver and you have bricked your keyboard and mouse. To use it on a USB-C equipped mac it needs to go through hub or a dongle to connect to the computer.

Normally this isn’t an issue, however, with this setup about once or twice a day the mouse and keyboard completely stops working. To fix it I need to unplug whatever hub the receiver is on and move it to another USB-C port. It’ll then merrily work again fora few hours until it happens again.

Oddities

  • In the “System Report” the receiver shows up as connected, but it just no longer accepts inputs.
  • Unplugging the receiver from the hub and plugging it back in does nothing. The whole setup needs to move to another port.
  • Any other USB 2.0 devices over USB-A that are plugged into that port via the hub also seem to freeze. My webcam, for example.
  • I have a backup setup and the same behavior happens with that one too. I’ve tried the official Apple multport adapter as well as a 3rd party option and it happens on both of them.
  • This all works on my iMac using its USB-A ports

But, the weirdest thing about this is that I leave the mouse turned off the keyboard will happily work fine with no issues.

I’ve contemplated just buying a good mouse and ditching the included mouse, but I would much rather just use this.

How can one even diagnose what’s going on?

I have no idea what to do from here. I’m open to trying literally anything if you think it might help.

Is there something I can check in console.app to see what is happening with USB devices? Is there an app out there that can help this?

Has anyone else run into this before? If so, please email me or reach out in another way!

mA Draw?

Yesterday I began to think that maybe it’s being caused by some sort of power draw spike? Like the mouse is requesting something from the receiver and it’s spiking the mA request through the hub and MacOS just cuts it off?

Would it be worth using a powered USB-C hub? Does that exist?

What about alternative setups?

I’ve looked for a similar style keyboard/mouse to replace this with, but no one seems to make one that is tenkeyless, which for my style of upper back pain is crucial. If someone knows of one though, please let me know!